Border CSS isn't working with blocks

Hi, I've been working on this for a few days but haven't managed to find a solution.

I'm using Dynamik with the new WP blocks. My Services page has some columns and I want to put a border around them. The borders look great in the CSS Builder preview but as soon as I save the code and refresh the page, the borders disappear.

It's not just the columns, borders don't work around paragraphs or headings either. It's like the new WP blocks are making them disappear. I didn't have this issue with the old style editor.

Can anyone help?

I'm beginning to think that Dynamik isn't compatible with Gutenberg columns and tables..

I can't get any decent formatting to work in them - no background colours, borders, list font sizes... nothing 😞

I've even tried the "hack" Eric mentioned for the font sizes in a previous post but that's not holding either. I typed the following into my stylesheet where "service-list" is my custom class for bullets. It all looks beautiful in the Dynamik preview, but disappears like an illicit lover as soon as it's saved.

.entry-content .service-list li {
font-size: 20px;
}

The error was mine. Shame on me for installing an old version of the theme. I upgraded my Dynamik version and it seems to be working now.

I've only tested quickly with a CSS border around the default column:
.wp-block-columns {
border: 5px solid #FFD736;
}

But the border is still there after saving so I'm hoping my troubles are over and it'll work with a custom class, which I'll try later.

Glad to have fixed that, by using this as my personal sounding board.

Moral of the story, if there's an error, check plugins and themes are at latest version. 🙂

Log in to reply