How can I use Genesis Extender to remove the sidebar from a single Genesis page?

My Genesis child theme has limited page templates, and always shows a right sidebar. I would like to remove that sidebar from my Privacy Policy page. Can I use Genesis Extender to do this, and if so, how?

I have the all access license so if another Cobalt Apps tool is more appropriate please advise.

Kevin

Hey Kevin,

Can you not simply select the no-sidebar Genesis Layout setting at the bottom of your Privacy Policy edit page?

The child theme does not provide the no-sidebar template as an option! The only options are Default Template (i.e. including the sidebar) and Blog Template. It's an old theme (Patricia: https://9seeds.com/product/patricia/).

I looked at the code, and it appears that the default Genesis templates which include the no-sidebar option are disabled specifically.

I can remove all the widgets from the sidebar, but the space occupied by the sidebar is still there. so the content area does not expand to full-width as I would like.

I was hoping there were some way I could simply override this annoyance by removing the sidebar area with one of the Cobalt tools.

The blog and default templates are the Page Templates included in Genesis, but I'm referring to the various Genesis Layouts that can be selected below the post editor area. They have light gray icons that represent the various content/sidebar layout options available for that Child Theme.

If they've disabled the Full Width Content layout then you should be able to re-enable it by using the following code inside a Custom Hook Box:

<?php
add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_full_width_content' );
?>

Just create a Custom Label, name it something like "Full Width Content", then once created you should be able to assign that your Custom Hook Box with the above code. Then got to that page editor screen again and select your "Full Width Content" Custom Label and see if that doesn't force the no sidebar layout that you're going for.

Thank you, Eric. That worked exactly like I wanted it to!

Glad to hear it! 🙂

Log in to reply