No 'space' in front end CSS editor when using Autoptimize plugin

I noticed this two times before. When using the Autoptimize plugin together with the Dynamic Website Builder, using a space in the front end CSS editor works fine, but when using the Extender plugin, hitting the spacebar doesn't result in a space, it just doesn't respond.

I noticed this with Genesis and with using the default Genesis child theme or with the Monochrome Pro theme together with the Extender plugin and the Autoptimize plugin. The Autoptimize plugin is quite popular.

@Webkompaan

I just tested this out and you are correct, except that even with Dynamik, though you can make a space, the syntax highlighting is completely gone and it really doesn't work either. This is only when you set Autoptimize to "Optimize JavaScript Code". Any of the other optimizations options seem to work fine without conflict, but it looks like the Autoptimize Plugin, when set to optimize the JS code of your site, somehow "breaks" the Ace Editor JS script we use for that front-end CSS editor.

Now as to how, I'm not sure, but at this point I have no solution. All I can say is that I'm now aware of it and will keep my eyes peeled for a potential solution. Just note that I can't really help if a Plugin breaks my code when trying to optimize it. It's possible that there's just some conflict between our script (which is a popular 3rd party script) and that Plugin. I'm not sure at this point. 🤔

Log in to reply