Genesis Simple Edits wants Genesis v 3.1.0 -

I'm trying to update my Footer using Genesis Simple Edits. I get an error saying "Genesis Simple Edits requires WordPress 5.0.0 and Genesis 3.1.0, or greater. Please upgrade to the latest version of Genesis to use this plugin."

There's a link to upgrade and the link takes me to a Studiopress login page - but I don't have a login because I purchased the Dynamik-Gen from here. Studiopress doesn't seem to have a way of creating an account without making another purchase (unless I just can't see it)

My Genesis is set to update automatically and mine is showing at v2.10.1

Is there another way I can update Genesis to 3.1.0?

Genesis should auto-update for you. The only thing that would prevent that from happening is if you have Dynamik set to use pre-HTML5 markup. To ensure that setting is set to HTML5 instead, go to Dynamik Settings > General Settings > Genesis HTML5 Markup and make sure the "Activate Genesis HTML5 Markup" option is checked. The Genesis Framework no longer supports non-HTML5 markup so this option is required with the latest version of Genesis. Once this is done you can go to the "Updates" section of your WP Dashboard and see if Genesis is now available to update.

Thanks very much, Eric. That fixed it, the update showed up immediately.

The HTML5 Markup setting has broken some of my CSS but I'm not live yet so I'll go through it with a fine-tooth comb. I appreciate your help.

Glad to hear it. Yes, you'll find things like #header has changed to .site-header and stuff like that. Below is part of a function that Dynamik uses to convert all the affected CSS elements from HTML to HTML5. The top array are the HTML5 elements and the bottom array are the pre-HTML5 elements. Hope that helps:

	if( dynamik_get_settings( 'html_five_active' ) )
	{
		$html_markup = array(
			'site_container' => '.site-container',
			'site_header' => '.site-header',
			'title_area' => '.title-area',
			'site_title' => '.site-title',
			'site_description' => '.site-description',
			'nav_primary' => '.nav-primary',
			'nav_secondary' => '.nav-secondary',
			'site_inner' => '.site-inner',
			'content_sidebar_wrap' => '.content-sidebar-wrap',
			'content' => '.content',
			'entry_header_entry_meta' => '.entry-header .entry-meta',
			'entry_footer_entry_meta' => '.entry-footer .entry-meta',
			'pagination' => '.pagination',
			'sidebar_primary' => '.sidebar-primary',
			'sidebar_secondary' => '.sidebar-secondary',
			'site_footer' => '.site-footer',
			'author_box_title' => '.author-box-title',
			'author_box_content' => '.author-box-content',
			'comment_author_link' => '.comment-author span',
			'comment_meta' => '.comment-meta',
			'comment_reply' => '.comment-reply',
			'entry_pings' => '.entry-pings',
			'respond_label' => 'display: block;',
			'search_form' => '.search-form',
			'search_form_search' => '.search-form input[type="search"]',
			'search_form_submit' => '.search-form input[type="submit"]'
		);
	}
	else
	{
		$html_markup = array(
			'site_container' => '#wrap',
			'site_header' => '#header',
			'title_area' => '#title-area',
			'site_title' => '#title',
			'site_description' => '#description',
			'nav_primary' => '#nav',
			'nav_secondary' => '#subnav',
			'site_inner' => '#inner',
			'content_sidebar_wrap' => '#content-sidebar-wrap',
			'content' => '#content',
			'entry_header_entry_meta' => '.post-info',
			'entry_footer_entry_meta' => '.post-meta',
			'pagination' => '.navigation',
			'sidebar_primary' => '#sidebar',
			'sidebar_secondary' => '#sidebar-alt',
			'site_footer' => '#footer',
			'author_box_title' => '.author-box strong',
			'author_box_content' => '.author-box p',
			'comment_author_link' => '.comment-author cite',
			'comment_meta' => '.commentmetadata',
			'comment_reply' => '.reply',
			'entry_pings' => '#pings',
			'respond_label' => '',
			'search_form' => '.searchform',
			'search_form_search' => '.s',
			'search_form_submit' => '.searchsubmit'
		);
	}

Perfect, thanks again 🙂

Sure thing. 🙂

Log in to reply